NAS

WD My Cloud에 새 하드 설치하는 방법 + 공장초기화

우성군 47 46731 0

마이 클라우드의 내장 HDD는 상당히 좋은 WD RED 하드입니다.




그래서 이번에 자작NAS의 저장장치로 쓰기 위해 분해하였습니다.



그러다보니 마이 클라우드의 본체가 아까워서 MBL의 WD GREEN 하드를 설치해보기로 했습니다.


(참고로 전 MBL이 두개있습니다 ^^;)




MBL도 RED나 GREEN 둘다 잘 된다고 하더군요.


(최근에 공홈에서 구입하신 분 중에 RED 하드가 들어있다는 분이 많이 계시더군요 ㅠㅠ)



어쨌든 분해 후 GREEN 하드에 이미지를 덮어씁니다.



통이미지는 


http://www.wsgvet.com/bbs/board.php?bo_table=iomega&wr_id=452


위 링크에 있습니다.


2TB, 3TB, 4TB 모두 있습니다.



그리고 복구하는 방법은


http://www.wsgvet.com/bbs/board.php?bo_table=iomega&wr_id=160


위 링크에서 


물리적으로 초기화하는 방법을 보시면 되고,


2. 파일 다운로드 (3)의 파일을 위의 통이미지로 대체하면 됩니다.



그리고 중요한 덮어쓰는 명령어를 


dd if=/mnt/usb/mybook3tb.img of=/dev/sda bs=1M


대신에


dd if=/mnt/usb/mycloud2tb.img of=/dev/sda bs=1M


이런 식으로 넣으면 됩니다.



마지막으로


http://www.ppomppu.co.kr/zboard/view.php?id=nas&no=1285


위와 같이 덮어쓴 후 reboot 명령어를 넣어 재부팅하면


최종적으로 느낌표가 사라지면서 정상적으로 복원이 됩니다.


혹시나 저처럼 2TB보다 많은 HDD를 넣었다면 GPARTED를 통하여 파티션을 늘려야 합니다.



그리고 하드를 마이 클라우드 본체와 조립한 후 랜선 꼽고 전원 넣으면


공유기에서 IP가 똭 뜹니다. ^^


이건 공장초기화나 마찬가지겠네요. ㅎㅎ



파일 전송속도는 RED하드나 GREEN하드나 차이가 없더라구요.


아무래도 마클의 CPU가 속도에 제한을 거는 느낌입니다.

, , , , ,

47 Comments
선구자 08.02 11:33  
노트북에 Ubuntu 설치했습니다.
1.  my cloud에서 적출 한 하드 연결 하고 fdisk -l 해보니

Device        Start              End                    Sectors                Size      Type
/dev/sdb4 9428992      5860532223        8851103232      2.7T      Microsoft basic data

이것을
mount -t ntfs  /dev/sdb4 /media/extusb/ 로 마운트 하는데
혹은 ntfs-3g
failed to access volume 'dev/sdb4' " No such file of Directory

Type때문에 나는 에러 같은데...
자료가 다 죽은것은 아닌지 걱정이 되네요 ㅠ

---
추가
fidsk -l 은 뜨는데

   
선구자2 13:51 ReplySecret
hhopc선생님 한번더 질문드릴게요..
fdisk -l 하면 
Device      Start        End    Sectors  Size Type
/dev/sdb1  1032192    5031935    3999744  1.9G Linux RAID
/dev/sdb2  5031936    9031679    3999744  1.9G Linux RAID
/dev/sdb3    30720    1032191    1001472  489M Microsoft basic data
/dev/sdb4  9428992 5860532223 5851103232  2.7T Microsoft basic data
/dev/sdb5  9031680    9226239    194560  95M Microsoft basic data
/dev/sdb6  9226240    9422847    196608  96M Microsoft basic data
/dev/sdb7  9422848    9424895      2048    1M Microsoft basic data
/dev/sdb8  9424896    9428991      4096    2M Microsoft basic data

분명 /dev/sdb4가 보이는데

root@dcbc:~# mout -t ntfs-3g /dev/s 하고 텝을 누르면
sdb4가 보이지 않네요..

sda      sdb      sdb5      sg0      snapshot  stdin   
sda1      sdb1      sdb6      sg1      snd/      stdout   
sda2      sdb2      sdb7      sg2      sr0     
sda5      sdb3      sdb8      shm/      stderr

/dev/sdb4는 존재하지 않네요 ㅠㅠ

root@dcbc:/dev# cd sdb
sdb  sdb1  sdb2  sdb3  sdb5  sdb6  sdb7  sdb8
우성군 08.03 00:59  
[@선구자] 에공 마운트하면 잘 안될수도 있을 듯 합니다.

저는 3.5인치 외장하드 케이스를 사서 거기에 하드를 넣고 우분투에서 외장하드를 연결시켜줬습니다.

그러면 바로 데이터에 접근 가능하거든요. 내부에서 마운트 하는 것은 저도 해보질 않아 잘 모르겠습니다 ㅠㅠ
선구자 08.03 09:30  
[@우성군] 아..ㅠㅠ 제것이 문제가 있군요
좋은 하루 되세요
우성군 08.04 00:51  
[@선구자] 문제가 있는지 없는지는 잘 모르겠어요 ㅠㅠ

다만 외장하드를 이용해서 한번 접근해보세요.
선구자 08.04 08:19  
[@우성군] 3.5인치 외장하드 케이스에 연결한 것인데

재생 하드가 들어있어서 망가진게 아닐까 하는 주관적인 생각입니다 ㅠㅠ

우성군님 바쁘신데도 댓글 달아주셔서 감사드립니다

좋은 하루 되세요
우성군 08.05 00:14  
[@선구자] 폴더가 보인다는 것은 아직 구조는 살아있는 것 같은데요.

좀더 찾아보시는 것이 좋을 것 같습니다. 어딘가에 있을 것 같은데요 흐흑
선구자 08.07 10:49  
[@우성군] 감사합니다^^
좋은 한주 되세요