Pogoplug

데비안 위지에서 Nginx 최신 버전으로 업그레이드 하기 (Debian Wheezy)

우성군 1 7596 0

기존에 Nginx 버전이 1.2.1이라서 업그레이드 하려고 찾아봤습니다.


관련 링크에 있는 내용과 거의 같습니다.



nano /etc/apt/sources.list


위 명령어로 소스로 들어갑니다.



deb http://ftp.debian.org/debian/ wheezy-backports main contrib non-free


위 내용 추가 후 저장 (혹시 wheezy-backports 내용이 있다면 뒤에 문구만 똑같이 넣어주면 됩니다.)



apt-get update


위 명령어로 업데이트 후



apt-get -t wheezy-backports install nginx


위 명령어로 설치하면 최신버전으로 업그레이드 됩니다.


2014년 8월 31일 현재 1.6.0 버전으로 업그레이드 됩니다. (현재 안정판 최신버전이 1.6.1 이므로 나름 높은 편이라 볼 수 있습니다.)



혹시 install 명령어에서


다음 패키지를 과거 버전으로 유지합니다:

  php-pear php5-cgi php5-cli php5-common php5-curl php5-dev php5-fpm php5-gd

  php5-mcrypt php5-mysql



위와 같이 유지하는 내용이 있다면, 업데이트 할 것이 남아있다는 말입니다.



그럴 경우 nginx와 같이 


apt-get -t wheezy-backports install php-pear php5-cgi php5-cli php5-common php5-curl php5-dev php5-fpm php5-gd php5-mcrypt php5-mysql


위와 같이 명령어를 넣어주면 wheezy-backports의 최신버전에 맞게 업그레이드 됩니다.


2014년 8월 31일 현재 5.4.4-14+deb7u14 버전으로 업그레이드 됩니다.

, , , , , , , , ,

1 Comments
우성군 2014.09.02 23:24  
오늘 패키지 업그레이드 하니 Nginx 1.6.1-1~bpo70+1 버전으로 올라가네요.